Back to overview
Degraded
Increase of CDN Page Errors
Mar 23, 2026 at 8:45am UTC
Affected services
DC-EU-GER-FRA-001
Resolved
Mar 23, 2026 at 8:58am UTC
This issue is resolved now
Affected services
Updated
Mar 23, 2026 at 8:58am UTC
A fix have had been pushed. We're monitoring the results
Affected services
Created
Mar 23, 2026 at 8:45am UTC
We're aware of an increase of CDN CGI Errors
Affected services